Flextype CMS 0.8.0 est sorti avec de nombreuses améliorations - Voici comment installer / mettre à niveau sur Ubuntu 16.04 | 18.04

  • George Richardson
  • 0
  • 4801
  • 1290

Flextype, un système de gestion de contenu (CMS) open source à fichiers plats très rapide et facile à configurer, a été mis à jour 0.8.0 avec le bateau chargé de changements… Ces changements sont de nombreuses nouvelles fonctionnalités et corrections qui améliorent la stabilité et les performances du système…

Ce bref didacticiel montre aux étudiants et aux nouveaux utilisateurs comment installer ou mettre à niveau Flextype CMS sur Ubuntu 16.04 | 18.04…

Certains de ces changements incluent, un nouveau dossier / site / entrées / ajouté à la plate-forme principale, une nouvelle fonctionnalité d'extraits de code ajoutée, une nouvelle fonctionnalité de menus ajoutée et bien d'autres encore

Si vous utilisez une version précédente de Flextype, il est peut-être temps de mettre à niveau pour profiter de certaines de ces nouvelles fonctionnalités… .

Pour en savoir plus sur cette version, veuillez consulter sa version postérieure. Voici quelques-uns des éléments ajoutés à cette version:

Ajoutée

  • Flextype Core: pour améliorer la flexibilité du moteur, il a été décidé d'utiliser le nom d'entité Entrées / Entrée au lieu du nom d'entité Pages / Page.
  • Flextype Core: nouveau dossier / site / entrées / ajoutée.
  • Flextype Core: Nouvelle variable d'entrée base_url ajoutée.
  • Flextype Core: ajout de la fonctionnalité Snippets.
  • Flextype Core: Nouvelle constante PATH ['snippets'] ajoutée pour les extraits.
  • Flextype Core: nouveau dossier / site / snippets / ajoutée.
  • Flextype Core: fonctionnalité de menus ajoutée.
  • Flextype Core: nouveau dossier / site / menus / ajoutée.
  • Flextype Core: fonctionnalité de jeux de champs ajoutée.
  • Flextype Core: fonctionnalité de secours pour les paramètres ajoutés.
  • Flextype Core: nouvel élément de paramètres accept_file_types ajouté.
  • Flextype Core: Remplacements PHP courants ajoutés à .htaccess

Modifié

  • Flextype Core: Plugins - Tableau de paramètres régionaux mis à jour.
  • Flextype Core: composants de formulaire mis à jour vers la version 1.0.2.
  • Flextype Core: composants du système de fichiers mis à jour vers la version 1.1.5.
  • Flextype Core: Content - nouvelle méthode getFilesList () mise à jour.
  • Flextype Core: Mise à jour de l'ordre des paramètres dans la méthode getEntries ().
  • Panneau d'administration: Gestionnaire de paramètres - affiche uniquement les paramètres régionaux disponibles.
  • Panneau d'administration: Gestionnaire de profils - améliorations de l'apparence et de la convivialité du profil.
  • Panneau d'administration: Gestionnaire d'entrées - Form Genetator ne créera pas d'étiquettes pour les entrées masquées.

Si vous n'avez pas encore installé Flextype CMS et que vous souhaitez apprendre à l'installer, cliquez sur l'un des liens ci-dessous… Le premier lien vous montre comment installer Flextype CMS avec le support Apache2 et l'autre vous montre comment le faire avec Nginx… .

Installation de Flextype avec la prise en charge d'Apache2

Pour savoir comment installer Flextype CMS avec la prise en charge HTTP Apache2, cliquez sur le lien ci-dessous:

Installez Flextype CMS sur Ubuntu 16.04 | 17.10 | 18.04 avec Apache2, MariaDB, PHP 7.2 et les certificats Let's Encrypt SSL / TLS

Installation du CMS Flextype avec le support Nginx

Pour installer Flextype avec le support Nginx, utilisez le lien ci-dessous:

Configurer Flextype CMS sur Ubuntu 16.04 | 17.10 | 18.04 avec les certificats Nginx, MariaDB, PHP 7.2 et Let's Encrypt SSL / TLS

Mise à niveau de Flextype

Le moyen le plus simple d'installer et de gérer Flextype est via Composer…. Suivez les étapes ci-dessous pour toujours obtenir la dernière version:

Vous pouvez facilement installer Flextype avec Composer.

compositeur créer-projet flextype / flextype

Installer les bibliothèques du fournisseur pour le thème par défaut

composer installer le site cd / thèmes / par défaut npm installer gulp 

Installer les bibliothèques du fournisseur pour le panneau d'administration

cd site / plugins / admin composer installer npm installer gulp

C'est ça!
Vous pouvez également aimer le message ci-dessous:

EspoCRM 5.5.2 est sorti - Voici comment installer / mettre à niveau sur Ubuntu 16.04 | 18.04




Personne n'a encore commenté ce post.

Une collection utiles sur le système Linux et les nouvelles technologies
Articles frais, conseils pratiques, critiques détaillées et guides. Sentez-vous comme chez vous dans le monde du système Linux